Minecraft Wiki

The Minecraft Wiki is no longer considered as official by Microsoft and therefore several changes are required to be made, including to the wiki's logo. Please read this announcement for more information.

READ MORE

Minecraft Wiki
Advertisement

Anchor for current PC version[]

The anchor for current PC version is not working because of a space after the "#" (eg, has #_1.2.3 instead of #1.2.3).– Scaler (t) 12:48, 19 March 2012 (UTC)

This is actually a problem with Template:Version. –ultradude25 (T|C) at 07:18, 20 March 2012 (UTC)
And now it's fixed. –ultradude25 (T|C) at 07:27, 20 March 2012 (UTC)

MC Xbox360 Beta 1.8.2 bug fix update[]

Please change the version to: "Current Xbox 360 edition: 1.2.1 –Preceding unsigned comment was added by Ramonms2 (Talk|Contribs) 22:24, 23 November 2012 (UTC). Please sign your posts with ~~~~

Done. ディノ千?!? · ☎ Dinoguy1000 04:05, 24 November 2012 (UTC)

Launcher link[]

Since {{version}} now supports links, can a function be added here for the launcher? It would link to Minecraft launcher's history section. --KnightMiner (t|c) 01:30, 19 July 2014 (UTC)

Some new pages to be whitelisted[]

Any snapshot with "13w", plus all versions back to 1.5 have been updated to the new format. Can they get added to the "new version pages"? Maybe something like this:

{{ #switch: {{#explode:{{{1|}}}|.|1}} | 5 | 6 | 7 | 8 | 9 = 1 }}{{ #pos: {{{1}}} | 13w }}{{ #pos: {{{1}}} | 14w }}

--KnightMiner (t|c) 15:21, 4 August 2014 (UTC)

 Done MajrTalk
Contribs
⎜ 06:40, 7 August 2014 (UTC)
I just noticed a slight issue, since I though it rendered Beta and alike after. It is not too major of a concern, since all those pages are redirects. To fix it
{{#explode:{{{1|}}}|.|1}} | 5 | 6 | 7 | 8 | 9 = 1 }}
could be replaced with
{{ #if: {{ #pos: {{{1|}}} }} || {{#explode:{{{1|}}}|.|1}} | 5 | 6 | 7 | 8 | 9 = 1 }} }}
Basically, it blacklists any titles with a space in the middle, such as "Beta 1.8".
On another note, I see why you don't like this template.
--KnightMiner (t|c) 22:11, 7 August 2014 (UTC)
Now all the PC version pages back to 1.0.0 have been been migrated, so some of this template is no longer needed.
I got a good working version here, which removes the developement versions and set the default to a standard link, rather then a sectional link of Version history. I ran a batch test on it and it still seems functions correctly with other version types. --KnightMiner (t|c) 23:54, 16 August 2014 (UTC)

Change category[]

Can an admin change the category from Category:Templates to Category:Link templates? This template still uses the old style, and is protected via main page cascading. KnightMiner (t·c) 02:08, 5 January 2015 (UTC)

Done. -- Orthotopetalk 02:25, 5 January 2015 (UTC)
Thanks! KnightMiner (t·c) 02:48, 5 January 2015 (UTC)

Switch Pocket Edition 0.8.0 - 0.11.x to new links[]

Well, the Pocket Edition versions back to 0.8.0 have been split, so I have an update to the template here. It basically links anything that is 0.8.0 through 0.11.x to the article under the name "Pocket Edition Alpha <text after pocket prefix>", plus makes the bracket code slightly better and applies {{release version}} to the default title.

There is going to be a future issue of updating links from "pocket 0.11.0" to "pocket alpha 0.11.0" assuming PE exits alpha stage, but for now I just told the template to treat them as the same.

KnightMiner t/c 03:27, 5 May 2015 (UTC)

Since the rest of the Pocket Edition versions have been split, I wrote up a new version here which links all Pocket Edition versions to the new format. (it also fixes some minor bugs I noticed since the implementation of my previous version, which were just some variants of "Pocket Edition" I forgot to add) KnightMiner t/c 20:41, 7 May 2015 (UTC)

Update Pi Edition links[]

Yep, that time again. The Pi edition needs plain old links rather than sections. I've written up an update here which does just that. KnightMiner t/c 17:26, 29 June 2015 (UTC)

Bump KnightMiner t/c 18:06, 10 November 2015 (UTC)
 Done MajrTalk
Contribs
09:59, 11 November 2015 (UTC)

console edition anchor[]

I think current anchors are not exact enough. If PS3 or PS4 is detected in {{{1}}}, #ps3-1.22 #ps4-1.22 is more proper. For wiiu, code like wiiu-{{#replace:{{#replace:{{v|wiiu=1|nolink=1}}|Patch|}}||}}. For xboxes, TUXX should be xbox-TUXX, CUXX should be xbone-CUXX. a20001017Talk 09:46, 7 February 2016 (UTC)

What benefit do the more complicated anchors hold? They are hardly "more proper" as almost all other current anchors are sentence titles. The current anchors simplify template code and are more easily human readable (TU7 makes more sense as TU7, not xbox-TU7), along with not requiring separate anchors for all PS versions (as they link the same spot anyways).
Also, per Module talk:Version/Numbers#Wii U Edition, it seems like "Patch" is not technically correct for the Wii U version, unless we switch all PS versions to the format of "Patch 1.22" KnightMiner t/c 20:48, 7 February 2016 (UTC)
Fine.a20001017Talk 03:36, 8 February 2016 (UTC)

Bedrock Edition[]

Kindly update the code into

<includeonly>[[{{Release version|{{
  #if: {{ #pos: {{ lc: {{{1}}} }} | pocket }}{{ #pos: {{ lc: {{{1}}} }} | pe }}  <!-- Pocket Edition -->
  | {{#if: {{ #pos: {{lc: {{{1|}}} }} | alpha }}{{ #pos: {{lc: {{{1|}}} }} | beta }}
    |{{#dplreplace: {{{1|}}} | /^((pocket edition{{!}}pocket{{!}}pe)( alpha{{!}} beta)?)/i | Pocket Edition Alpha }} 
    |{{#dplreplace: {{{1|}}} | /^(pocket edition{{!}}pocket{{!}}pe)/i | Pocket Edition }}
    }}
  |{{#if: {{ #pos: {{ lc: {{{1}}} }} | ps3 }}{{ #pos: {{ lc: {{{1}}} }} | xbox }}{{ #pos: {{ lc: {{{1}}} }} | console }} <!-- Console Edition -->
    | Console Edition version history#{{
      #if: {{ #pos: {{{1}}} | ) }}              <!-- If there's brackets, a date is assumed and is used as the anchor instead of a version number -->
      | {{ #dplreplace: {{{1|}}} | .*?\((.*?)\) | \1 }}
      | {{ #explode: {{{1}}} | | -1 }}
    }}
    |{{ #if: {{ #pos: {{ lc: {{{1}}} }} | launcher }}
      | Minecraft launcher#{{ #explode: {{{1}}} | | -1 }}
      | {{#if: {{ #pos: {{ lc: {{{1}}} }} | bedrock }}{{ #pos: {{ lc: {{{1}}} }} | be }}  <!-- Bedrock Edition -->
        | {{#dplreplace: {{{1|}}} | /^(bedrock edition{{!}}bedrock{{!}}be)/i | Bedrock Edition }}
        | {{{1}}}<!-- Otherwise just try the link directly -->
      }}
    }}
  }}
}}}}|{{{2|{{Release version|{{{1}}}}}}}}]]</includeonly><noinclude>
{{documentation}}
<!-- Put categories/interwiki on the documentation page -->
</noinclude>

=D – Dentedharp90041tce 11:20, 24 September 2017 (UTC)

Protected edit request[]

Can the all PS4 prefixes be changed to link to "PlayStation 4 Edition {1}" as redirects (now/should) exist for all updates. – Nixinova Nixinova sig1.png Nixinova sig2.png 22:05, 17 April 2019 (UTC)

@Nixinova: Thanks for the request. I'm not great when it comes to templates, would you mine specifying exactly what code needs to be changed to what?--Madminecrafter12 (Talk to me | View what I've done) 00:41, 23 April 2019 (UTC)
Also noting that if another admin who is more familiar with this template can fulfill this request, please do so.--Madminecrafter12 (Talk to me | View what I've done) 00:43, 23 April 2019 (UTC)
I've made the changes in Template:Sandbox, so just copy and paste what's in there. I added a test so if the ps4 version is less than 1.82, it links to the version history page, but if it's equal or above it links directly to the PlayStation 4 Edition 1.xx page. – Nixinova Nixinova sig1.png Nixinova sig2.png 00:58, 23 April 2019 (UTC)
Advertisement